Installing snapd

Snaps can be used on all major Linux distributions, including Ubuntu, Linux Mint, Debian and Fedora.

If you’re running Ubuntu 16.04.4 LTS (Xenial Xerus) or later, including the latest Ubuntu 18.04 LTS (Bionic Beaver), you don’t need to do anything. The snap environment is already installed and ready to go.

For other Linux distributions, including older Ubuntu releases, you will need to install the snap environment before snaps can be installed.

Distribution support

Use the links below for specific installation instructions for each distribution.

Last updated 22 days ago. Help improve this document in the forum.