The ruby plugin

The ruby plugin is useful for Ruby-based parts.

The gem package manager and an associated Gemfile are used to install dependencies.

This plugin uses the common plugin keywords as well as those for “sources”. For more information, see Snapcraft parts metadata.

Additionally, this plugin uses the following plugin-specific keywords:

  • gems (list)
    A list of gems to install.
  • use-bundler (boolean)
    Use bundler to install gems from a Gemfile (defaults to ‘false’).
  • ruby-version (string)
    The version of ruby you want this snap to run.

For examples, search GitHub for projects already using the plugin.

This is a snapcraft plugin. See Snapcraft plugins and Supported plugins for further details on how plugins are used.

Last updated 25 days ago. Help improve this document in the forum.